import re
regex = re.compile(r"\w*[@]\w+[.]\w{0,4}", flags=re.MULTILINE)
test_str = ("harsh@gmail.com\n"
"rahultrivedi180@gmail.com\n"
"lol@.com\n"
"hello.com\n"
"@.com\n"
"rahultrivedi180@hotmail.com\n"
"glsica.org\n"
"glsica@gmail.com\n"
"rrhul_@yahoo.in")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")