using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(?![ \/]+$))(?=[ \/a-z0-9]{1,20}).*$";
string input = @"asdas//A9898AAA";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}