$re = '/(?=(?![ \/]+$))(?=[ \/a-z0-9]{1,20}).*$/';
$str = 'asdas//A9898AAA';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);