use strict;
my $str = '<script type="text/javascript">ViewGifImage(this, \'sitedb/log/QA/General/SfpBCTuningCheck/gfx/qa_2023-02-01-212831-1.gif\',\'sitedb/log/QA/General/SfpBCTuningCheck/gfx/qa_2023-02-01-212831-1.pix\',\'322\',\'242\',\'ReflectionResultPlot\',\'Frequency in MHz\',\'0\',\'Reflection Factor |r|\',\'0\',\'1\',\'xffffff x000000 x000000 xff0000 x0000ff x00df00 xff00ff xff7f00\',\'2\',\'158\',\'1\',\'Reflection 0 Degrees\',\'158\',\'1\',\'Reflection 90 Degrees\',\'\',\'\',\'\',\'\',\'\',\'\',\'\',\'\',\'\')
</script>
<script type="text/javascript">ViewGifImage(this, \'sitedb/log/QA/General/SfpBCTuningCheck/gfx/qa_2023-02-01-212831-2.gif\',\'sitedb/log/QA/General/SfpBCTuningCheck/gfx/qa_2023-02-01-212831-2.pix\',\'322\',\'242\',\'TransmissionResultPlot\',\'Frequency in MHz\',\'0\',\'Transmission |t| in db\',\'0\',\'1\',\'xffffff x000000 x000000 xff0000 x0000ff x00df00 xff00ff xff7f00\',\'2\',\'158\',\'1\',\'Transmission 0 Degrees\',\'158\',\'1\',\'Transmission 90 Degrees\',\'\',\'\',\'\',\'\',\'\',\'\',\'\',\'\',\'\')
</script>';
my $regex = qr/(<script.*-(1|2)\.gif.*<\/script>)/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}