$re = '/(<script.*-(1|2)\.gif.*<\/script>)/sU';
$str = '<script type="text/javascript">ViewGifImage(this, \'sitedb/log/QA/General/SfpBCTuningCheck/gfx/qa_2023-02-01-212831-1.gif\',\'sitedb/log/QA/General/SfpBCTuningCheck/gfx/qa_2023-02-01-212831-1.pix\',\'322\',\'242\',\'ReflectionResultPlot\',\'Frequency in MHz\',\'0\',\'Reflection Factor |r|\',\'0\',\'1\',\'xffffff x000000 x000000 xff0000 x0000ff x00df00 xff00ff xff7f00\',\'2\',\'158\',\'1\',\'Reflection 0 Degrees\',\'158\',\'1\',\'Reflection 90 Degrees\',\'\',\'\',\'\',\'\',\'\',\'\',\'\',\'\',\'\')
</script>
<script type="text/javascript">ViewGifImage(this, \'sitedb/log/QA/General/SfpBCTuningCheck/gfx/qa_2023-02-01-212831-2.gif\',\'sitedb/log/QA/General/SfpBCTuningCheck/gfx/qa_2023-02-01-212831-2.pix\',\'322\',\'242\',\'TransmissionResultPlot\',\'Frequency in MHz\',\'0\',\'Transmission |t| in db\',\'0\',\'1\',\'xffffff x000000 x000000 xff0000 x0000ff x00df00 xff00ff xff7f00\',\'2\',\'158\',\'1\',\'Transmission 0 Degrees\',\'158\',\'1\',\'Transmission 90 Degrees\',\'\',\'\',\'\',\'\',\'\',\'\',\'\',\'\',\'\')
</script>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);