#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(['""])((?:\\1|(?:(?!\1)).)*)(\1)|(?<OpenMatch>({))|(?<CloseMatch>(}))"
Local $sString = "if (!(new[] { "Command", "Click" }).Any(d => xmlAttribute.Name.Equals(d," & @CRLF & _
"StringComparison.CurrentCultureIgnoreCase))) continue;" & @CRLF & _
"if (!baseChain.Name.Contains(':')) return chain;" & @CRLF & _
"var checkAnyInherited = baseChain.Name.Split(':').Last().Split(',', ' ').Where(d => !string.IsNullOrEmpty(d)).Select(d => d.Trim()).ToList();" & @CRLF & _
"private static IEnumerable<StatementReferenceMaster> GetAllMethodsForClass(string className, int projectId)" & @CRLF & _
" {" & @CRLF & _
" using (ICodeVortoService codeVortoService = new CodeVortoService())" & @CRLF & _
" {" & @CRLF & _
" object[] parametersExp =" & @CRLF & _
" {" & @CRLF & _
" new MySqlParameter("@delim", MySqlDbType.VarChar) {Value = ","}," & @CRLF & _
" new MySqlParameter("@className", MySqlDbType.VarChar) {Value = className}," & @CRLF & _
" new MySqlParameter("@prjId", MySqlDbType.Int32) {Value = projectId}" & @CRLF & _
" };" & @CRLF & _
" var callExtExpandedCode = codeVortoService.StatementReferenceMasterRepository" & @CRLF & _
" .ExecuteStoreProcedure<StatementReferenceMaster>("SpGetAllMethodsForClass", parametersExp)" & @CRLF & _
" .ContinueWith(t => t.Result).Result;" & @CRLF & _
" return callExtExpandedCode;" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"@"CREATE\s+TABLE"" & @CRLF & _
"@"\`(.*?)\`\s+\("" & @CRLF & _
"@"^\`(.*?)\`(.*)"" & @CRLF & _
"@"^PRIMARY\s+KEY"" & @CRLF & _
"@"(.*)\((.*)\)"" & @CRLF & _
"""" & @CRLF & _
"""" & @CRLF & _
"""" & @CRLF & _
""("" & @CRLF & _
""-"" & @CRLF & _
""DbScript"" & @CRLF & _
" @"CREATE\s+TABLE\s+(\[dbo\].)?(\[)?(\`)?(?<TableName>[a-zA-Z0-9_$]+)(\])?(\`)?"" & @CRLF & _
"@"^([\s]+)?(\[|\`)?(?<FieldName>[a-zA-Z0-9_$]+)(\]|\`)?"" & @CRLF & _
""TableName"" & @CRLF & _
" @"C:\inetpub\wwwroot\flokapture\ExtractedProjects\LocationServicesSource\Pods.Integration.Services.Location.Model\LocationServiceModel.edmx"" & @CRLF & _
"@"^<EntityContainer\s+Name=\""([^\""]*)\"""" & @CRLF & _
"@"^<EntityType\s+Name=\""([^\""]*)\"""" & @CRLF & _
"@"StoreEntitySet=\""([^\""]*)\"""" & @CRLF & _
"@"^<Property\s+"" & @CRLF & _
"@"^<EntityType\s+Name=\""([^\""]*)\""|^<Property\s+|^</EntityType>\s+"" & @CRLF & _
""<edmx:Mappings>"" & @CRLF & _
""</EntityType>"" & @CRLF & _
""Done"" & @CRLF & _
""SELECT * FROM EntityAttributes WHERE ProjectId = " " & @CRLF & _
" " Group by EntityName;"" & @CRLF & _
" @"(?<VariableName>[a-z_]+)\s*=\s*new\s+[a-z.0-9]+?" " & @CRLF & _
" "\\(\\)|[\\s]*[\\w]+\\s+(?<VariableName>[a-zA-Z0-9$_]+)[\\s]*=[\\s]*"" & @CRLF & _
""." "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")