package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[[^\]]*\]\.|[\[\]]`)
var str = `[MercadosArmados.GpoMerc-CTN3].[Mercado Marketing SNC].[Mk Alprazolam], [MercadosArmados.GpoMerc-CTN3].[Mercado Marketing SNC].[Mk Amantadina]`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}