re = /\[[^\]]*\]\.|[\[\]]/
str = '[MercadosArmados.GpoMerc-CTN3].[Mercado Marketing SNC].[Mk Alprazolam], [MercadosArmados.GpoMerc-CTN3].[Mercado Marketing SNC].[Mk Amantadina]'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result