using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z]+0*";
string substitution = @"";
string input = @"DE73456
DE71238
FR00034
FR00036
ES00038
US00039
DE00098";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}