package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[a-z0-9][a-z0-9-]*(\[(\d)+-(\d)+\])?(\.[a-z0-9]+)*$`)
var str = `l-ops[1-9].cn9`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}