re = /^[a-z0-9][a-z0-9-]*(\[(\d)+-(\d)+\])?(\.[a-z0-9]+)*$/
str = 'l-ops[1-9].cn9'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end