import re
regex = re.compile(r"^(([1-9]?[0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-5])\.){3}([1-9]?[0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-5])$", flags=re.MULTILINE)
test_str = ("172.18.0.25\n"
"254.0.24.36\n"
"127.0.0.1\n"
"127.0.0.256\n"
"0.21.02.0214\n"
"25.14.23.0\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")