#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\R(?!Module Statements,)"
Local $sString = "Module Statements,Module,Collection of primitive building blocks and instances of other modules that comprise a network and or instrument. Two types handoff or internal,A redefinition of a module_def shall overwrite a previously defined module_def having the same module_name within the same nameSpace_name.,6.4.5.a)," & @CRLF & _
"Module Statements,,,A module_def shall have at least one port_def unless it is the top module and contains an AccessLink statement,6.4.5.b)," & @CRLF & _
"Module Statements,,,"The following objects shall have unique names within a module_def:" & @CRLF & _
"port_name" & @CRLF & _
"? scanRegister_name" & @CRLF & _
"? dataRegister_name" & @CRLF & _
"? one_hot_scan_group_name" & @CRLF & _
"? scanMux_name" & @CRLF & _
"? dataMux_name" & @CRLF & _
"? clockMux_name" & @CRLF & _
"? one_hot_data_group_name" & @CRLF & _
"? logicSignal_name" & @CRLF & _
"? alias_name",6.4.5.c)," & @CRLF & _
"Module Statements,,,"The following objects shall have unique names within a module_def:" & @CRLF & _
"instance_name" & @CRLF & _
"? scanInterface_name",6.4.5.d)," & @CRLF & _
"Module Statements,,,"An inputPort_name shall be one of the following" & @CRLF & _
"scanInPort_name" & @CRLF & _
"? shiftEnPort_name" & @CRLF & _
"? captureEnPort_name" & @CRLF & _
"? updateEnPort_name" & @CRLF & _
"? dataInPort_name" & @CRLF & _
"? selectPort_name" & @CRLF & _
"? resetPort_name" & @CRLF & _
"? tmsPort_name" & @CRLF & _
"? tckPort_name" & @CRLF & _
"? clockPort_name" & @CRLF & _
"? trstPort_name" & @CRLF & _
"? addressPort_name" & @CRLF & _
"? writeEnPort_name" & @CRLF & _
"? readEnPort_name" & @CRLF & _
"",6.4.5.e)," & @CRLF & _
"Module Statements,,,"An outputPort_name shall be one of the following:" & @CRLF & _
"? scanOutPort_name" & @CRLF & _
"? dataOutPort_name" & @CRLF & _
"? toShiftEnPort_name" & @CRLF & _
"? toUpdateEnPort_name" & @CRLF & _
"? toCaptureEnPort_name" & @CRLF & _
"? toSelectPort_name" & @CRLF & _
"? toResetPort_name" & @CRLF & _
"? toTckPort_name" & @CRLF & _
"? toTmsPort_name" & @CRLF & _
"? toClockPort_name" & @CRLF & _
"? toTrstPort_name" & @CRLF & _
"? toIRSelectPort_name",6.4.5.f)," & @CRLF & _
"Module Statements,,,Multiple inputPort_name port functions that are of type vector_id may share the same SCALAR_ID as long as the indexes form a contiguous range and every index range is of the same either ascending or descending type.,6.4.5.g)," & @CRLF & _
"Module Statements,,,Multiple outputPort_name port functions that are of type vector_id may share the same SCALAR_ID as long as the indexes form a contiguous range and every index range is of the same either ascending or descending type.,6.4.5.h),"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)