# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\R(?!Module Statements,)"
test_str = ("Module Statements,Module,Collection of primitive building blocks and instances of other modules that comprise a network and or instrument. Two types handoff or internal,A redefinition of a module_def shall overwrite a previously defined module_def having the same module_name within the same nameSpace_name.,6.4.5.a),\n"
"Module Statements,,,A module_def shall have at least one port_def unless it is the top module and contains an AccessLink statement,6.4.5.b),\n"
"Module Statements,,,\"The following objects shall have unique names within a module_def:\n"
"port_name\n"
"? scanRegister_name\n"
"? dataRegister_name\n"
"? one_hot_scan_group_name\n"
"? scanMux_name\n"
"? dataMux_name\n"
"? clockMux_name\n"
"? one_hot_data_group_name\n"
"? logicSignal_name\n"
"? alias_name\",6.4.5.c),\n"
"Module Statements,,,\"The following objects shall have unique names within a module_def:\n"
"instance_name\n"
"? scanInterface_name\",6.4.5.d),\n"
"Module Statements,,,\"An inputPort_name shall be one of the following\n"
"scanInPort_name\n"
"? shiftEnPort_name\n"
"? captureEnPort_name\n"
"? updateEnPort_name\n"
"? dataInPort_name\n"
"? selectPort_name\n"
"? resetPort_name\n"
"? tmsPort_name\n"
"? tckPort_name\n"
"? clockPort_name\n"
"? trstPort_name\n"
"? addressPort_name\n"
"? writeEnPort_name\n"
"? readEnPort_name\n"
"\",6.4.5.e),\n"
"Module Statements,,,\"An outputPort_name shall be one of the following:\n"
"? scanOutPort_name\n"
"? dataOutPort_name\n"
"? toShiftEnPort_name\n"
"? toUpdateEnPort_name\n"
"? toCaptureEnPort_name\n"
"? toSelectPort_name\n"
"? toResetPort_name\n"
"? toTckPort_name\n"
"? toTmsPort_name\n"
"? toClockPort_name\n"
"? toTrstPort_name\n"
"? toIRSelectPort_name\",6.4.5.f),\n"
"Module Statements,,,Multiple inputPort_name port functions that are of type vector_id may share the same SCALAR_ID as long as the indexes form a contiguous range and every index range is of the same either ascending or descending type.,6.4.5.g),\n"
"Module Statements,,,Multiple outputPort_name port functions that are of type vector_id may share the same SCALAR_ID as long as the indexes form a contiguous range and every index range is of the same either ascending or descending type.,6.4.5.h),")
subst = " "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.