#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<label for=".*">(.*)<\/label>"
Local $sString = "<body>" & @CRLF & _
"<form name="catalogue" action="test.php" method="GET">" & @CRLF & _
" <div class="container">" & @CRLF & _
" <div class="row">" & @CRLF & _
" <div class="col">" & @CRLF & _
" <div class="form-group m-1">" & @CRLF & _
" <label for="product">product</label>" & @CRLF & _
" <select id="product" name="product" onChange="submitForm(this);">" & @CRLF & _
" <option value="compliment_slips" >Μηνύματα αλληλογραφίας</option>" & @CRLF & _
" <option value="stickers" selected >Aυτοκόλλητα</option>" & @CRLF & _
" <option value="floor sticker" >Aυτοκόλλητα δαπέδου</option>" & @CRLF & _
" <option value="trolly token" >Kέρματα για καρότσι αγορώv</option>" & @CRLF & _
" <option value="banner" >L-banners</option>" & @CRLF & _
" <option value="soft mousepad" >Mousepads</option>" & @CRLF & _
" <option value="walls" >Pop-up stands</option>" & @CRLF & _
" <option value="popup tower" >Pop-up πυλώνας</option>" & @CRLF & _
" <option value="rollups" >Roll-up banners</option>" & @CRLF & _
" <option value="phone case" >Smartphone-φωτο/φίες</option>" & @CRLF & _
" <option value="sweater" >Sweatshirts/Πουλόβερ</option>" & @CRLF & _
" <option value="tablet case" >Tablet-φωτο/φίες</option>" & @CRLF & _
" <option value="door_hanger" >Tαμπελακια πορτας</option>" & @CRLF & _
" <option value="x-banner" >X-banners</option>" & @CRLF & _
" <option value="blowups_xxlBanner" >XXL banners</option>" & @CRLF & _
" <option value="sports t-shirt" >Αθλητικά T-shirts</option>" & @CRLF & _
" <option value="sport shorts" >Αθλητικά παντελόνια κοντά/σορτς</option>" & @CRLF & _
" <option value="sports bag" >Αθλητικές τσάντες</option>" & @CRLF & _
" <option value="sports jersey" >Αθλητικές φανέλες</option>" & @CRLF & _
" <option value="lighter" >Αναπτήρες</option>" & @CRLF & _
" <option value="bottle opener" >Ανοιχτήρια</option>" & @CRLF & _
" <option value="cinnamon star" >Αστέρια κανέλας</option>" & @CRLF & _
" <option value="NCR paper" >Αυτογραφικά μπλοκ/σετ</option>" & @CRLF & _
" <option value="sticky_notes" >Αυτοκόλλητα χαρτάκια</option>" & @CRLF & _
" <option value="poster" >Αφίσες</option>" & @CRLF & _
" <option value="twin wall poster" >Αφίσες κυψελωτού φύλλου</option>" & @CRLF & _
" <option value="printbook" >Βιβλία</option>" & @CRLF & _
" <option value="sewn book" >Βιβλία με συρραφή φύλλων</option>" & @CRLF & _
" <option value="note book" >Βιβλία σημειώσεων</option>" & @CRLF & _
" <option value="wristlet" >Βραχιολάκια εισόδου</option>" & @CRLF & _
" <option value="waistcoat" >Γιλέκα</option>" & @CRLF & _
" <option value="sports stocking" >Γκέτες</option>" & @CRLF & _
" <option value="magazine inkjet" >Δέσιμο συγκόλλησης (PUR) Oικονομικό</option>" & @CRLF & _
" <option value="parking disc" >Δίσκοι στάθμευσης</option>" & @CRLF & _
" <option value="outdoor banner" >Διαφημιστικά πλαίσια</option>" & @CRLF & _
" <option value="folded card" >Διπλή κάρτα</option>" & @CRLF & _
" <option value="entrance ticket" >Εισιτήρια</option>" & @CRLF & _
" <option value="businesscard" >Επαγγελματικές κάρτες</option>" & @CRLF & _
" <option value="letterheads" >Επιστολόχαρτα</option>" & @CRLF & _
" <option value="desk calendar" >Επιτραπέζια ημερολόγια</option>" & @CRLF & _
" <option value="place mat" >Επιτραπέζια σετ</option>" & @CRLF & _
" <option value="place_cards" >Επιτραπέζιες κάρτες</option>" & @CRLF & _
" <option value="table_stands" >Επιτραπέζιες κάρτες</option>" & @CRLF & _
" <option value="year planner" >Ετήσια ημερολόγια</option>" & @CRLF & _
" <option value="label" >Ετικέτες</option>" & @CRLF & _
" <option value="tab" >Ευρετήρια (διαχωριστικά φύλλα)</option>" & @CRLF & _
" <option value="fruit gum" >Ζελίνια φρούτων</option>" & @CRLF & _
" <option value="calendars" >Ημερολόγια</option>" & @CRLF & _
" <option value="punched pocket" >Θήκες από ζελατίνα</option>" & @CRLF & _
" <option value="slipcase" >Θήκες βιβλίων</option>" & @CRLF & _
" <option value="magazine file" >Θήκες περιοδικών</option>" & @CRLF & _
" <option value="tablet wallet" >Θήκες υπολογιστή ταμπλέτα</option>" & @CRLF & _
" <option value="bonus_cards" >Κάρτες μπόνους</option>" & @CRLF & _
" <option value="appointment_cards" >Κάρτες υπενθύμισης</option>" & @CRLF & _
" <option value="basecap" >Καπέλα τζόκεϊ</option>" & @CRLF & _
" <option value="drop" >Καραμέλες</option>" & @CRLF & _
" <option value="postcards" >Καρτποστάλ</option>" & @CRLF & _
" <option value="binder" >Κλασέρ</option>" & @CRLF & _
" <option value="adhesive film" >Κολλητικές μεμβράνες</option>" & @CRLF & _
" <option value="sticky tape" >Κολλητικές ταινίες πακέτων</option>" & @CRLF & _
" <option value="keychain" >Κορδόνια λαιμού</option>" & @CRLF & _
" <option value="frame" >Κορνίζες</option>" & @CRLF & _
" <option value="presentation cases" >Κουτιά αρχείων</option>" & @CRLF & _
" <option value="pillow box" >Κουτιά μαξιλάρια</option>" & @CRLF & _
" <option value="gable box" >Κουτιά τσάντες</option>" & @CRLF & _
" <option value="stretcher frame" >Λινά υφάσματα</option>" & @CRLF & _
" <option value="photo stretcher frame" >Λινά φωτο-υφάσματα</option>" & @CRLF & _
" <option value="magnetic foil" >Μαγνητικές μεμβράνες</option>" & @CRLF & _
" <option value="longsleeves" >Μακρυμάνικες</option>" & @CRLF & _
" <option value="gingerbread" >Μελομακάρονα</option>" & @CRLF & _
" <option value="backlit film" >Μεμβράνες για κιβώτιο με φως</option>" & @CRLF & _
" <option value="menue_cards" >Μενού</option>" & @CRLF & _
" <option value="measuring tape" >Μετροταινίες</option>" & @CRLF & _
" <option value="month panel calendar" >Μηνιαία ημερολόγια</option>" & @CRLF & _
" <option value="pencil" >Μολύβια</option>" & @CRLF & _
" <option value="tarpaulin" >Μουσαμάδες/Πανό</option>" & @CRLF & _
" <option value="note_pad" >Μπλοκ</option>" & @CRLF & _
" <option value="t-shirt" >Μπλουζάκια</option>" & @CRLF & _
" <option value="polo shirt" >Μπλούζες πόλο</option>" & @CRLF & _
" <option value="bathrobe" >Μπουρνούζια</option>" & @CRLF & _
" <option value="jacket" >Μπουφάν</option>" & @CRLF & _
" <option value="workwear jacket" >Μπουφάν εργασίας</option>" & @CRLF & _
" <option value="keyring pendant" >Μπρελόκ</option>" & @CRLF & _
" <option value="folder" >Ντοσιέ</option>" & @CRLF & _
" <option value="writing folder" >Ντοσιέ γραφείου</option>" & @CRLF & _
" <option value="ring folder" >Ντοσιέ με κρίκους</option>" & @CRLF & _
" <option value="ice scraper" >Ξέστρες πάγου</option>" & @CRLF & _
" <option value="wine box" >Οινοκιβώτια</option>" & @CRLF & _
" <option value="shop counter" >Πάγκοι προβολής</option>" & @CRLF & _
" <option value="clipboard" >Πίνακες σεμιναρίων</option>" & @CRLF & _
" <option value="gift tag" >Παντατίφ δώρα</option>" & @CRLF & _
" <option value="workwear pants" >Παντελόνια εργασίας</option>" & @CRLF & _
" <option value="magazine" >Περιοδικά/Κατάλογοι</option>" & @CRLF & _
" <option value="towel" >Πετσέτες</option>" & @CRLF & _
" <option value="fabric frame" >Πλαίσια τεντώματος υφασμάτων</option>" & @CRLF & _
" <option value="plastic card" >Πλαστικές κάρτες</option>" & @CRLF & _
" <option value="apron" >Ποδιές</option>" & @CRLF & _
" <option value="shirt" >Πουκάμισα ανδρικά</option>" & @CRLF & _
" <option value="blouse" >Πουκάμισα γυναικεία</option>" & @CRLF & _
" <option value="brochure" >Προσπέκτους</option>" & @CRLF & _
" <option value="tuck box" >Πτυσσόμενα κουτιά</option>" & @CRLF & _
" <option value="handle box" >Πτυσσόμενα κουτιά με λαβή μεταφοράς</option>" & @CRLF & _
" <option value="folding rule" >Πτυσσόμενα μέτρα</option>" & @CRLF & _
" <option value="postal box" >Πτυσσόμενα πλαίσια</option>" & @CRLF & _
" <option value="chefs jacket" >Σακάκια μάγειρα</option>" & @CRLF & _
" <option value="bookmark" >Σελιδοδείκτες</option>" & @CRLF & _
" <option value="postit set" >Σετ σημειώσεων</option>" & @CRLF & _
" <option value="promotional sign" >Σημάνσεις/Εκτύπωση επιφανειών</option>" & @CRLF & _
" <option value="hoisting flag" >Σημαίες</option>" & @CRLF & _
" <option value="flags" >Σημαίες παραλίας</option>" & @CRLF & _
" <option value="beanie" >Σκουφιά</option>" & @CRLF & _
" <option value="chocolate" >Σοκολάτες</option>" & @CRLF & _
" <option value="desk_pad" >Σουμέν γραφείου</option>" & @CRLF & _
" <option value="stopper" >Σταντ αφισών</option>" & @CRLF & _
" <option value="sliding box" >Συρταρωτά κουτιά</option>" & @CRLF & _
" <option value="stamp" >Σφραγίδα</option>" & @CRLF & _
" <option value="bottle_hanger" >Ταμπελάκια φιαλών</option>" & @CRLF & _
" <option value="dextrose" >Ταμπλέτες γλυκόζης</option>" & @CRLF & _
" <option value="telescope box" >Τηλεσκοπικά κουτιά με πτερύγια</option>" & @CRLF & _
" <option value="bag" >Τσάντες</option>" & @CRLF & _
" <option value="fabric banner" >Υφασμάτινο banners</option>" & @CRLF & _
" <option value="plug case" >Φάκελος απο χαρτόνι</option>" & @CRLF & _
" <option value="flyer" >Φέιγ βολάν/Δίπτυχα</option>" & @CRLF & _
" <option value="hoody" >Φούτερ με κουκούλα</option>" & @CRLF & _
" <option value="hoody jacket" >Φούτερ με κουκούλα και φερμουάρ</option>" & @CRLF & _
" <option value="booklet cd dvd" >Φυλλάδια CD/DVD</option>" & @CRLF & _
" <option value="collage" >Φωτο-κολάζ</option>" & @CRLF & _
" <option value="puzzle" >Φωτο-παζλ</option>" & @CRLF & _
" <option value="door plate" >Φωτο-ταμπέλες πόρτας</option>" & @CRLF & _
" <option value="wallpaper" >Φωτο-ταπετσαρίες</option>" & @CRLF & _
" <option value="wall picture" >Φωτο-τοιχογραφίες</option>" & @CRLF & _
" <option value="cup" >Φωτο-φλιτζάνια</option>" & @CRLF & _
" <option value="printing sheet" >Φύλλα εκτύπωσης</option>" & @CRLF & _
" <option value="ruler" >Χάρακες</option>" & @CRLF & _
" <option value="cd cover" >Χάρτινα εξώφυλλα CD/DVD</option>" & @CRLF & _
" <option value="wrapping paper" >Χαρτιά δώρων</option>" & @CRLF & _
" <option value="napkin" >Χαρτοπετσέτες</option>" & @CRLF & _
" <option value="envelope" >Χαρτοφάκελοι</option>" & @CRLF & _
" <option value="waiter_pads" >μπλοκ σερβιτόρου</option>" & @CRLF & _
" <option value="brochure wireO" >σπιράλ βιβλιο</option>" & @CRLF & _
" </select>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="form-group m-1">" & @CRLF & _
" <label for="c_format">c_format</label>" & @CRLF & _
" <select id="c_format" name="c_format" onChange="submitForm(this);">" & @CRLF & _
" <option value="C_37_x_52_mm_DIN-A-9" >37 x 52 mm DIN A9</option>" & @CRLF & _
" <option value="C_50_x_20_mm_(abgerundete_Ecken)" >50 x 20 mm (στρογγυλεμένες γωνίες)</option>" & @CRLF & _
" <option value="C_52_x_74_mm_DIN-A-8" >52 x 74 mm DIN A8</option>" & @CRLF & _
" <option value="C_70_x_25_mm_(abgerundete_Ecken)" >70 x 25 mm (στρογγυλεμένες γωνίες)</option>" & @CRLF & _
" <option value="C_74_x_105_mm_DIN-A-7" selected >74 x 105 mm DIN A7</option>" & @CRLF & _
" <option value="C_85_x_55_mm" >85 x 55 mm</option>" & @CRLF & _
" <option value="C_85_x_55_mm_(abgerundete_Ecken)" >85 x 55 mm (στρογγυλεμένες γωνίες)</option>" & @CRLF & _
" <option value="C_98_x_210_mm_DIN_Lang" >98 x 210 mm DIΝ φαρδύ</option>" & @CRLF & _
" <option value="C_105_x_148_mm_DIN-A-6" >105 x 148 mm A6</option>" & @CRLF & _
" <option value="C_105_x_297_mm_Long-Size" >105 x 297 mm</option>" & @CRLF & _
" <option value="C_148_x_210_mm_DIN-A-5" >148 x 210 mm DIN A5</option>" & @CRLF & _
" <option value="C_210_x_297_mm_DIN-A-4" >210 x 297 mm DIN A4</option>" & @CRLF & _
" <option value="C_297_x_420_mm_DIN-A-3" >297 x 420 mm DIN A3</option>" & @CRLF & _
" <option value="C_40_mm_Rund" >40 mm Στρογγυλό</option>" & @CRLF & _
" <option value="C_80_mm_Rund" >80 mm Στρογγυλό</option>" & @CRLF & _
" <option value="C_145_x_95_mm_Oval" >145 x 95 mm Οβάλ</option>" & @CRLF & _
" </select>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="form-group m-1">" & @CRLF & _
" <label for="c_format_dir">c_format_dir</label>" & @CRLF & _
" <select id="c_format_dir" name="c_format_dir" onChange="submitForm(this);">" & @CRLF & _
" <option value="C_panel_format" selected >Κάθετο</option>" & @CRLF & _
" <option value="C_landscape_format" >Οριζόντιο</option>" & @CRLF & _
" </select>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="form-group m-1">" & @CRLF & _
" <label for="c_paper">c_paper</label>" & @CRLF & _
" <select id="c_paper" name="c_paper" onChange="submitForm(this);">" & @CRLF & _
" <option value="C_Haft_gloss_permanent_klebend" selected >Αυτοκόλλητο λευκό χαρτί (κατάλληλο για εσωτερική χρήση)</option>" & @CRLF & _
" <option value="C_PP-Folie" >Aυτοκόλλητη μεμβράνη λευκή (κατάλληλη για εξωτερική χρήση)</option>" & @CRLF & _
" </select>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="form-group m-1">" & @CRLF & _
" <label for="c_color">c_color</label>" & @CRLF & _
" <select id="c_color" name="c_color" onChange="submitForm(this);">" & @CRLF & _
" <option value="C_1/0-farbig_Black" >1/0-χρωμο Μαύρο</option>" & @CRLF & _
" <option value="C_4/0-farbig_Euroskala" selected >4/0-χρωμο CMYK</option>" & @CRLF & _
" </select>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="form-group m-1">" & @CRLF & _
" <label for="c_processing">c_processing</label>" & @CRLF & _
" <select id="c_processing" name="c_processing" onChange="submitForm(this);">" & @CRLF & _
" <option value="C_Cutt" selected >Κοπή</option>" & @CRLF & _
" </select>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="form-group m-1">" & @CRLF & _
" <label for="c_finishing">c_finishing</label>" & @CRLF & _
" <select id="c_finishing" name="c_finishing" onChange="submitForm(this);">" & @CRLF & _
" <option value="C_Ohne_Finishing" selected >Χωρίς</option>" & @CRLF & _
" </select>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="form-group m-1">" & @CRLF & _
" <label for="c_finishing_desc">c_finishing_desc</label>" & @CRLF & _
" <select id="c_finishing_desc" name="c_finishing_desc" onChange="submitForm(this);">" & @CRLF & _
" <option value="C_Ohne_Veredelung" selected >Χωρίς</option>" & @CRLF & _
" </select>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="form-group m-1">" & @CRLF & _
" <label for="quantity">quantity</label>" & @CRLF & _
" <select id="quantity" name="quantity" onChange="submitForm(this);">" & @CRLF & _
" <option value="1_quantity" selected >1 Τεμάχια</option>" & @CRLF & _
" <option value="5_quantity" >5 Τεμάχια</option>" & @CRLF & _
" <option value="10_quantity" >10 Τεμάχια</option>" & @CRLF & _
" <option value="15_quantity" >15 Τεμάχια</option>" & @CRLF & _
" <option value="20_quantity" >20 Τεμάχια</option>" & @CRLF & _
" <option value="25_quantity" >25 Τεμάχια</option>" & @CRLF & _
" <option value="50_quantity" >50 Τεμάχια</option>" & @CRLF & _
" <option value="100_quantity" >100 Τεμάχια</option>" & @CRLF & _
" <option value="250_quantity" >250 Τεμάχια</option>" & @CRLF & _
" <option value="500_quantity" >500 Τεμάχια</option>" & @CRLF & _
" <option value="750_quantity" >750 Τεμάχια</option>" & @CRLF & _
" <option value="1000_quantity" >1000 Τεμάχια</option>" & @CRLF & _
" <option value="1500_quantity" >1500 Τεμάχια</option>" & @CRLF & _
" <option value="2000_quantity" >2000 Τεμάχια</option>" & @CRLF & _
" <option value="2500_quantity" >2500 Τεμάχια</option>" & @CRLF & _
" <option value="5000_quantity" >5000 Τεμάχια</option>" & @CRLF & _
" <option value="7500_quantity" >7500 Τεμάχια</option>" & @CRLF & _
" <option value="10000_quantity" >10000 Τεμάχια</option>" & @CRLF & _
" <option value="15000_quantity" >15000 Τεμάχια</option>" & @CRLF & _
" <option value="20000_quantity" >20000 Τεμάχια</option>" & @CRLF & _
" <option value="25000_quantity" >25000 Τεμάχια</option>" & @CRLF & _
" <option value="30000_quantity" >30000 Τεμάχια</option>" & @CRLF & _
" <option value="35000_quantity" >35000 Τεμάχια</option>" & @CRLF & _
" <option value="40000_quantity" >40000 Τεμάχια</option>" & @CRLF & _
" <option value="45000_quantity" >45000 Τεμάχια</option>" & @CRLF & _
" <option value="50000_quantity" >50000 Τεμάχια</option>" & @CRLF & _
" </select>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="form-group m-1">" & @CRLF & _
" <label for="packing">packing</label>" & @CRLF & _
" <select id="packing" name="packing" onChange="submitForm(this);">" & @CRLF & _
" <option value="without_packing" selected >Χωρίς</option>" & @CRLF & _
" </select>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="form-group m-1">" & @CRLF & _
" <label for="shipping">shipping</label>" & @CRLF & _
" <select id="shipping" name="shipping" onChange="submitForm(this);">" & @CRLF & _
" <option value="standard" selected >Παράδοση Κανονικό έως 30.08.</option>" & @CRLF & _
" <option value="economy" >Παράδοση Economy έως 03.09.</option>" & @CRLF & _
" <option value="express" >Παράδοση Εξπρές έως 29.08.</option>" & @CRLF & _
" <option value="priority" >Παράδοση Προτεραιότητα έως 22.08.</option>" & @CRLF & _
" </select>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
"</form>" & @CRLF & _
"<script>" & @CRLF & _
"function submitForm(O) {" & @CRLF & _
" var a = document.getElementsByTagName('select');" & @CRLF & _
" for (var i = 0; i < a.length; i++) {" & @CRLF & _
" if (a[i].selectedIndex == -1 && typeof empty === 'undefined') {" & @CRLF & _
" var empty = i;" & @CRLF & _
" }" & @CRLF & _
" if (a[i].name == O.name) {" & @CRLF & _
" var current = i;" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" var del = empty < current ? empty : current;" & @CRLF & _
" for (var i = 0; i < a.length; i++) {" & @CRLF & _
" if (i > del) {" & @CRLF & _
" a[i].selectedIndex = -1;" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" document.catalogue.submit();" & @CRLF & _
"}" & @CRLF & _
"</script> " & @CRLF & _
"" & @CRLF & _
"<!-- Optional JavaScript --> " & @CRLF & _
"<!-- jQuery first, then Popper.js, then Bootstrap JS --> " & @CRLF & _
"<script src="https://code.jquery.com/jquery-3.3.1.slim.min.js" integrity="sha384-q8i/X+965DzO0rT7abK41JStQIAqVgRVzpbzo5smXKp4YfRvH+8abtTE1Pi6jizo" crossorigin="anonymous"></script> " & @CRLF & _
"<script src="https://cdnjs.cloudflare.com/ajax/libs/popper.js/1.14.7/umd/popper.min.js" integrity="sha384-UO2eT0CpHqdSJQ6hJty5KVphtPhzWj9WO1clHTMGa3JDZwrnQq4sF86dIHNDz0W1" crossorigin="anonymous"></script> " & @CRLF & _
"<script src="https://stackpath.bootstrapcdn.com/bootstrap/4.3.1/js/bootstrap.min.js" integrity="sha384-JjSmVgyd0p3pXB1rRibZUAYoIIy6OrQ6VrjIEaFf/nJGzIxFDsf4x0xIM+B07jRM" crossorigin="anonymous"></script>" & @CRLF & _
"</body>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")