// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<label for=".*">(.*)<\/label>"#).unwrap();
let string = "<body>
<form name=\"catalogue\" action=\"test.php\" method=\"GET\">
<div class=\"container\">
<div class=\"row\">
<div class=\"col\">
<div class=\"form-group m-1\">
<label for=\"product\">product</label>
<select id=\"product\" name=\"product\" onChange=\"submitForm(this);\">
<option value=\"compliment_slips\" >Μηνύματα αλληλογραφίας</option>
<option value=\"stickers\" selected >Aυτοκόλλητα</option>
<option value=\"floor sticker\" >Aυτοκόλλητα δαπέδου</option>
<option value=\"trolly token\" >Kέρματα για καρότσι αγορώv</option>
<option value=\"banner\" >L-banners</option>
<option value=\"soft mousepad\" >Mousepads</option>
<option value=\"walls\" >Pop-up stands</option>
<option value=\"popup tower\" >Pop-up πυλώνας</option>
<option value=\"rollups\" >Roll-up banners</option>
<option value=\"phone case\" >Smartphone-φωτο/φίες</option>
<option value=\"sweater\" >Sweatshirts/Πουλόβερ</option>
<option value=\"tablet case\" >Tablet-φωτο/φίες</option>
<option value=\"door_hanger\" >Tαμπελακια πορτας</option>
<option value=\"x-banner\" >X-banners</option>
<option value=\"blowups_xxlBanner\" >XXL banners</option>
<option value=\"sports t-shirt\" >Αθλητικά T-shirts</option>
<option value=\"sport shorts\" >Αθλητικά παντελόνια κοντά/σορτς</option>
<option value=\"sports bag\" >Αθλητικές τσάντες</option>
<option value=\"sports jersey\" >Αθλητικές φανέλες</option>
<option value=\"lighter\" >Αναπτήρες</option>
<option value=\"bottle opener\" >Ανοιχτήρια</option>
<option value=\"cinnamon star\" >Αστέρια κανέλας</option>
<option value=\"NCR paper\" >Αυτογραφικά μπλοκ/σετ</option>
<option value=\"sticky_notes\" >Αυτοκόλλητα χαρτάκια</option>
<option value=\"poster\" >Αφίσες</option>
<option value=\"twin wall poster\" >Αφίσες κυψελωτού φύλλου</option>
<option value=\"printbook\" >Βιβλία</option>
<option value=\"sewn book\" >Βιβλία με συρραφή φύλλων</option>
<option value=\"note book\" >Βιβλία σημειώσεων</option>
<option value=\"wristlet\" >Βραχιολάκια εισόδου</option>
<option value=\"waistcoat\" >Γιλέκα</option>
<option value=\"sports stocking\" >Γκέτες</option>
<option value=\"magazine inkjet\" >Δέσιμο συγκόλλησης (PUR) Oικονομικό</option>
<option value=\"parking disc\" >Δίσκοι στάθμευσης</option>
<option value=\"outdoor banner\" >Διαφημιστικά πλαίσια</option>
<option value=\"folded card\" >Διπλή κάρτα</option>
<option value=\"entrance ticket\" >Εισιτήρια</option>
<option value=\"businesscard\" >Επαγγελματικές κάρτες</option>
<option value=\"letterheads\" >Επιστολόχαρτα</option>
<option value=\"desk calendar\" >Επιτραπέζια ημερολόγια</option>
<option value=\"place mat\" >Επιτραπέζια σετ</option>
<option value=\"place_cards\" >Επιτραπέζιες κάρτες</option>
<option value=\"table_stands\" >Επιτραπέζιες κάρτες</option>
<option value=\"year planner\" >Ετήσια ημερολόγια</option>
<option value=\"label\" >Ετικέτες</option>
<option value=\"tab\" >Ευρετήρια (διαχωριστικά φύλλα)</option>
<option value=\"fruit gum\" >Ζελίνια φρούτων</option>
<option value=\"calendars\" >Ημερολόγια</option>
<option value=\"punched pocket\" >Θήκες από ζελατίνα</option>
<option value=\"slipcase\" >Θήκες βιβλίων</option>
<option value=\"magazine file\" >Θήκες περιοδικών</option>
<option value=\"tablet wallet\" >Θήκες υπολογιστή ταμπλέτα</option>
<option value=\"bonus_cards\" >Κάρτες μπόνους</option>
<option value=\"appointment_cards\" >Κάρτες υπενθύμισης</option>
<option value=\"basecap\" >Καπέλα τζόκεϊ</option>
<option value=\"drop\" >Καραμέλες</option>
<option value=\"postcards\" >Καρτποστάλ</option>
<option value=\"binder\" >Κλασέρ</option>
<option value=\"adhesive film\" >Κολλητικές μεμβράνες</option>
<option value=\"sticky tape\" >Κολλητικές ταινίες πακέτων</option>
<option value=\"keychain\" >Κορδόνια λαιμού</option>
<option value=\"frame\" >Κορνίζες</option>
<option value=\"presentation cases\" >Κουτιά αρχείων</option>
<option value=\"pillow box\" >Κουτιά μαξιλάρια</option>
<option value=\"gable box\" >Κουτιά τσάντες</option>
<option value=\"stretcher frame\" >Λινά υφάσματα</option>
<option value=\"photo stretcher frame\" >Λινά φωτο-υφάσματα</option>
<option value=\"magnetic foil\" >Μαγνητικές μεμβράνες</option>
<option value=\"longsleeves\" >Μακρυμάνικες</option>
<option value=\"gingerbread\" >Μελομακάρονα</option>
<option value=\"backlit film\" >Μεμβράνες για κιβώτιο με φως</option>
<option value=\"menue_cards\" >Μενού</option>
<option value=\"measuring tape\" >Μετροταινίες</option>
<option value=\"month panel calendar\" >Μηνιαία ημερολόγια</option>
<option value=\"pencil\" >Μολύβια</option>
<option value=\"tarpaulin\" >Μουσαμάδες/Πανό</option>
<option value=\"note_pad\" >Μπλοκ</option>
<option value=\"t-shirt\" >Μπλουζάκια</option>
<option value=\"polo shirt\" >Μπλούζες πόλο</option>
<option value=\"bathrobe\" >Μπουρνούζια</option>
<option value=\"jacket\" >Μπουφάν</option>
<option value=\"workwear jacket\" >Μπουφάν εργασίας</option>
<option value=\"keyring pendant\" >Μπρελόκ</option>
<option value=\"folder\" >Ντοσιέ</option>
<option value=\"writing folder\" >Ντοσιέ γραφείου</option>
<option value=\"ring folder\" >Ντοσιέ με κρίκους</option>
<option value=\"ice scraper\" >Ξέστρες πάγου</option>
<option value=\"wine box\" >Οινοκιβώτια</option>
<option value=\"shop counter\" >Πάγκοι προβολής</option>
<option value=\"clipboard\" >Πίνακες σεμιναρίων</option>
<option value=\"gift tag\" >Παντατίφ δώρα</option>
<option value=\"workwear pants\" >Παντελόνια εργασίας</option>
<option value=\"magazine\" >Περιοδικά/Κατάλογοι</option>
<option value=\"towel\" >Πετσέτες</option>
<option value=\"fabric frame\" >Πλαίσια τεντώματος υφασμάτων</option>
<option value=\"plastic card\" >Πλαστικές κάρτες</option>
<option value=\"apron\" >Ποδιές</option>
<option value=\"shirt\" >Πουκάμισα ανδρικά</option>
<option value=\"blouse\" >Πουκάμισα γυναικεία</option>
<option value=\"brochure\" >Προσπέκτους</option>
<option value=\"tuck box\" >Πτυσσόμενα κουτιά</option>
<option value=\"handle box\" >Πτυσσόμενα κουτιά με λαβή μεταφοράς</option>
<option value=\"folding rule\" >Πτυσσόμενα μέτρα</option>
<option value=\"postal box\" >Πτυσσόμενα πλαίσια</option>
<option value=\"chefs jacket\" >Σακάκια μάγειρα</option>
<option value=\"bookmark\" >Σελιδοδείκτες</option>
<option value=\"postit set\" >Σετ σημειώσεων</option>
<option value=\"promotional sign\" >Σημάνσεις/Εκτύπωση επιφανειών</option>
<option value=\"hoisting flag\" >Σημαίες</option>
<option value=\"flags\" >Σημαίες παραλίας</option>
<option value=\"beanie\" >Σκουφιά</option>
<option value=\"chocolate\" >Σοκολάτες</option>
<option value=\"desk_pad\" >Σουμέν γραφείου</option>
<option value=\"stopper\" >Σταντ αφισών</option>
<option value=\"sliding box\" >Συρταρωτά κουτιά</option>
<option value=\"stamp\" >Σφραγίδα</option>
<option value=\"bottle_hanger\" >Ταμπελάκια φιαλών</option>
<option value=\"dextrose\" >Ταμπλέτες γλυκόζης</option>
<option value=\"telescope box\" >Τηλεσκοπικά κουτιά με πτερύγια</option>
<option value=\"bag\" >Τσάντες</option>
<option value=\"fabric banner\" >Υφασμάτινο banners</option>
<option value=\"plug case\" >Φάκελος απο χαρτόνι</option>
<option value=\"flyer\" >Φέιγ βολάν/Δίπτυχα</option>
<option value=\"hoody\" >Φούτερ με κουκούλα</option>
<option value=\"hoody jacket\" >Φούτερ με κουκούλα και φερμουάρ</option>
<option value=\"booklet cd dvd\" >Φυλλάδια CD/DVD</option>
<option value=\"collage\" >Φωτο-κολάζ</option>
<option value=\"puzzle\" >Φωτο-παζλ</option>
<option value=\"door plate\" >Φωτο-ταμπέλες πόρτας</option>
<option value=\"wallpaper\" >Φωτο-ταπετσαρίες</option>
<option value=\"wall picture\" >Φωτο-τοιχογραφίες</option>
<option value=\"cup\" >Φωτο-φλιτζάνια</option>
<option value=\"printing sheet\" >Φύλλα εκτύπωσης</option>
<option value=\"ruler\" >Χάρακες</option>
<option value=\"cd cover\" >Χάρτινα εξώφυλλα CD/DVD</option>
<option value=\"wrapping paper\" >Χαρτιά δώρων</option>
<option value=\"napkin\" >Χαρτοπετσέτες</option>
<option value=\"envelope\" >Χαρτοφάκελοι</option>
<option value=\"waiter_pads\" >μπλοκ σερβιτόρου</option>
<option value=\"brochure wireO\" >σπιράλ βιβλιο</option>
</select>
</div>
<div class=\"form-group m-1\">
<label for=\"c_format\">c_format</label>
<select id=\"c_format\" name=\"c_format\" onChange=\"submitForm(this);\">
<option value=\"C_37_x_52_mm_DIN-A-9\" >37 x 52 mm DIN A9</option>
<option value=\"C_50_x_20_mm_(abgerundete_Ecken)\" >50 x 20 mm (στρογγυλεμένες γωνίες)</option>
<option value=\"C_52_x_74_mm_DIN-A-8\" >52 x 74 mm DIN A8</option>
<option value=\"C_70_x_25_mm_(abgerundete_Ecken)\" >70 x 25 mm (στρογγυλεμένες γωνίες)</option>
<option value=\"C_74_x_105_mm_DIN-A-7\" selected >74 x 105 mm DIN A7</option>
<option value=\"C_85_x_55_mm\" >85 x 55 mm</option>
<option value=\"C_85_x_55_mm_(abgerundete_Ecken)\" >85 x 55 mm (στρογγυλεμένες γωνίες)</option>
<option value=\"C_98_x_210_mm_DIN_Lang\" >98 x 210 mm DIΝ φαρδύ</option>
<option value=\"C_105_x_148_mm_DIN-A-6\" >105 x 148 mm A6</option>
<option value=\"C_105_x_297_mm_Long-Size\" >105 x 297 mm</option>
<option value=\"C_148_x_210_mm_DIN-A-5\" >148 x 210 mm DIN A5</option>
<option value=\"C_210_x_297_mm_DIN-A-4\" >210 x 297 mm DIN A4</option>
<option value=\"C_297_x_420_mm_DIN-A-3\" >297 x 420 mm DIN A3</option>
<option value=\"C_40_mm_Rund\" >40 mm Στρογγυλό</option>
<option value=\"C_80_mm_Rund\" >80 mm Στρογγυλό</option>
<option value=\"C_145_x_95_mm_Oval\" >145 x 95 mm Οβάλ</option>
</select>
</div>
<div class=\"form-group m-1\">
<label for=\"c_format_dir\">c_format_dir</label>
<select id=\"c_format_dir\" name=\"c_format_dir\" onChange=\"submitForm(this);\">
<option value=\"C_panel_format\" selected >Κάθετο</option>
<option value=\"C_landscape_format\" >Οριζόντιο</option>
</select>
</div>
<div class=\"form-group m-1\">
<label for=\"c_paper\">c_paper</label>
<select id=\"c_paper\" name=\"c_paper\" onChange=\"submitForm(this);\">
<option value=\"C_Haft_gloss_permanent_klebend\" selected >Αυτοκόλλητο λευκό χαρτί (κατάλληλο για εσωτερική χρήση)</option>
<option value=\"C_PP-Folie\" >Aυτοκόλλητη μεμβράνη λευκή (κατάλληλη για εξωτερική χρήση)</option>
</select>
</div>
<div class=\"form-group m-1\">
<label for=\"c_color\">c_color</label>
<select id=\"c_color\" name=\"c_color\" onChange=\"submitForm(this);\">
<option value=\"C_1/0-farbig_Black\" >1/0-χρωμο Μαύρο</option>
<option value=\"C_4/0-farbig_Euroskala\" selected >4/0-χρωμο CMYK</option>
</select>
</div>
<div class=\"form-group m-1\">
<label for=\"c_processing\">c_processing</label>
<select id=\"c_processing\" name=\"c_processing\" onChange=\"submitForm(this);\">
<option value=\"C_Cutt\" selected >Κοπή</option>
</select>
</div>
<div class=\"form-group m-1\">
<label for=\"c_finishing\">c_finishing</label>
<select id=\"c_finishing\" name=\"c_finishing\" onChange=\"submitForm(this);\">
<option value=\"C_Ohne_Finishing\" selected >Χωρίς</option>
</select>
</div>
<div class=\"form-group m-1\">
<label for=\"c_finishing_desc\">c_finishing_desc</label>
<select id=\"c_finishing_desc\" name=\"c_finishing_desc\" onChange=\"submitForm(this);\">
<option value=\"C_Ohne_Veredelung\" selected >Χωρίς</option>
</select>
</div>
<div class=\"form-group m-1\">
<label for=\"quantity\">quantity</label>
<select id=\"quantity\" name=\"quantity\" onChange=\"submitForm(this);\">
<option value=\"1_quantity\" selected >1 Τεμάχια</option>
<option value=\"5_quantity\" >5 Τεμάχια</option>
<option value=\"10_quantity\" >10 Τεμάχια</option>
<option value=\"15_quantity\" >15 Τεμάχια</option>
<option value=\"20_quantity\" >20 Τεμάχια</option>
<option value=\"25_quantity\" >25 Τεμάχια</option>
<option value=\"50_quantity\" >50 Τεμάχια</option>
<option value=\"100_quantity\" >100 Τεμάχια</option>
<option value=\"250_quantity\" >250 Τεμάχια</option>
<option value=\"500_quantity\" >500 Τεμάχια</option>
<option value=\"750_quantity\" >750 Τεμάχια</option>
<option value=\"1000_quantity\" >1000 Τεμάχια</option>
<option value=\"1500_quantity\" >1500 Τεμάχια</option>
<option value=\"2000_quantity\" >2000 Τεμάχια</option>
<option value=\"2500_quantity\" >2500 Τεμάχια</option>
<option value=\"5000_quantity\" >5000 Τεμάχια</option>
<option value=\"7500_quantity\" >7500 Τεμάχια</option>
<option value=\"10000_quantity\" >10000 Τεμάχια</option>
<option value=\"15000_quantity\" >15000 Τεμάχια</option>
<option value=\"20000_quantity\" >20000 Τεμάχια</option>
<option value=\"25000_quantity\" >25000 Τεμάχια</option>
<option value=\"30000_quantity\" >30000 Τεμάχια</option>
<option value=\"35000_quantity\" >35000 Τεμάχια</option>
<option value=\"40000_quantity\" >40000 Τεμάχια</option>
<option value=\"45000_quantity\" >45000 Τεμάχια</option>
<option value=\"50000_quantity\" >50000 Τεμάχια</option>
</select>
</div>
<div class=\"form-group m-1\">
<label for=\"packing\">packing</label>
<select id=\"packing\" name=\"packing\" onChange=\"submitForm(this);\">
<option value=\"without_packing\" selected >Χωρίς</option>
</select>
</div>
<div class=\"form-group m-1\">
<label for=\"shipping\">shipping</label>
<select id=\"shipping\" name=\"shipping\" onChange=\"submitForm(this);\">
<option value=\"standard\" selected >Παράδοση Κανονικό έως 30.08.</option>
<option value=\"economy\" >Παράδοση Economy έως 03.09.</option>
<option value=\"express\" >Παράδοση Εξπρές έως 29.08.</option>
<option value=\"priority\" >Παράδοση Προτεραιότητα έως 22.08.</option>
</select>
</div>
</div>
</div>
</div>
</form>
<script>
function submitForm(O) {
var a = document.getElementsByTagName('select');
for (var i = 0; i < a.length; i++) {
if (a[i].selectedIndex == -1 && typeof empty === 'undefined') {
var empty = i;
}
if (a[i].name == O.name) {
var current = i;
}
}
var del = empty < current ? empty : current;
for (var i = 0; i < a.length; i++) {
if (i > del) {
a[i].selectedIndex = -1;
}
}
document.catalogue.submit();
}
</script>
<!-- Optional JavaScript -->
<!-- jQuery first, then Popper.js, then Bootstrap JS -->
<script src=\"https://code.jquery.com/jquery-3.3.1.slim.min.js\" integrity=\"sha384-q8i/X+965DzO0rT7abK41JStQIAqVgRVzpbzo5smXKp4YfRvH+8abtTE1Pi6jizo\" crossorigin=\"anonymous\"></script>
<script src=\"https://cdnjs.cloudflare.com/ajax/libs/popper.js/1.14.7/umd/popper.min.js\" integrity=\"sha384-UO2eT0CpHqdSJQ6hJty5KVphtPhzWj9WO1clHTMGa3JDZwrnQq4sF86dIHNDz0W1\" crossorigin=\"anonymous\"></script>
<script src=\"https://stackpath.bootstrapcdn.com/bootstrap/4.3.1/js/bootstrap.min.js\" integrity=\"sha384-JjSmVgyd0p3pXB1rRibZUAYoIIy6OrQ6VrjIEaFf/nJGzIxFDsf4x0xIM+B07jRM\" crossorigin=\"anonymous\"></script>
</body>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}