using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[A-Z]+\.(\d{4})(\d{2})\.V(\d+)\.\w+";
string input = @"ABCD.202011.V2.txt
QWERTY.201120.V1.csv
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}