re = /\b[A-Z]+\.(\d{4})(\d{2})\.V(\d+)\.\w+/m
str = 'ABCD.202011.V2.txt
QWERTY.201120.V1.csv
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end