$re = '/(?<!\p{C})\b\w+\b(?!\p{C})/m';
$str = 'word without control characters
word with control character ‎between';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);