# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<result>(?<data>^[\d|,]+)(?: in )(?<cat>.+?)(?<extra>\s+(?:\(.+?\)?)?))$/$3 = $2/gm;t' <<< "286,879 in Home & Kitchen (See Top 100 in Home & Kitchen)
339 in Cardboard Cutouts
2,945 in Jigsaws (Toys & Games)"