use strict;
my $str = '286,879 in Home & Kitchen (See Top 100 in Home & Kitchen)
339 in Cardboard Cutouts
2,945 in Jigsaws (Toys & Games)';
my $regex = qr/(?<result>(?<data>^[\d|,]+)(?: in )(?<cat>.+?)(?<extra>\s+(?:\(.+?\)?)?))$/mp;
my $subst = '$3 = $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";