package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`2845CT;([^,]+)`)
var str = `2810X000000466,,APQ4LA805C34REUGJU,2845AP;2810X000000467,,4985,2845ER;2810X000000468,,361301760100,2845CT;2810X000000469,,DV361301760100,2845NC;2810X000000470,,APQ4LA805C34REUGJU,2845NA;2810X000189003,,BC,2845PS;2810X000267245,,E00137336,2845OA;2810X000267246,,E01027004,2845LS;2810X000267247,,E02005628,2845MS;2810X000331704,,C,284599;2810X000384460,,01/04/1993,284591`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}