const regex = /2845CT;([^,]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('2845CT;([^,]+)', 'g')
const str = `2810X000000466,,APQ4LA805C34REUGJU,2845AP;2810X000000467,,4985,2845ER;2810X000000468,,361301760100,2845CT;2810X000000469,,DV361301760100,2845NC;2810X000000470,,APQ4LA805C34REUGJU,2845NA;2810X000189003,,BC,2845PS;2810X000267245,,E00137336,2845OA;2810X000267246,,E01027004,2845LS;2810X000267247,,E02005628,2845MS;2810X000331704,,C,284599;2810X000384460,,01/04/1993,284591`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}