#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m),\s*"
Local $sString = "1,5,7,9,8,3,6,2,4," & @CRLF & _
"" & @CRLF & _
"2,6,8,7,5,4,9,3,1," & @CRLF & _
"" & @CRLF & _
"9,4,3,6,1,2,7,5,8," & @CRLF & _
"" & @CRLF & _
"8,9,2,1,7,6,5,4,3," & @CRLF & _
"" & @CRLF & _
"3,1,6,5,4,8,2,7,9," & @CRLF & _
"" & @CRLF & _
"5,7,4,3,2,9,1,8,6," & @CRLF & _
"" & @CRLF & _
"7,3,5,4,6,1,8,9,2," & @CRLF & _
"" & @CRLF & _
"6,8,9,2,3,5,4,1,7," & @CRLF & _
"" & @CRLF & _
"4,2,1,8,9,7,3,6,5,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")