use strict;
my $str = '1,5,7,9,8,3,6,2,4,
2,6,8,7,5,4,9,3,1,
9,4,3,6,1,2,7,5,8,
8,9,2,1,7,6,5,4,3,
3,1,6,5,4,8,2,7,9,
5,7,4,3,2,9,1,8,6,
7,3,5,4,6,1,8,9,2,
6,8,9,2,3,5,4,1,7,
4,2,1,8,9,7,3,6,5,';
my $regex = qr/,\s*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}