const regex = /(^\w+\s\d+\s+\d+:\d+:\d+)\s+\w+\.\w+\s+[\w=\w+]+\[(\d+)]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^\\w+\\s\\d+\\s+\\d+:\\d+:\\d+)\\s+\\w+\\.\\w+\\s+[\\w=\\w+]+\\[(\\d+)]', 'gm')
const str = `Jul 6 14:01:23 computer.name CRON[29440]: USER (good_user)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}