re = /(^\w+\s\d+\s+\d+:\d+:\d+)\s+\w+\.\w+\s+[\w=\w+]+\[(\d+)]/m
str = 'Jul 6 14:01:23 computer.name CRON[29440]: USER (good_user)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end