const regex = /((^[^|\n]+\||\G)[^|\n]+)\|/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((^[^|\\n]+\\||\\G)[^|\\n]+)\\|', 'gm')
const str = `контура|силуэта|абриса|профиля
контурам|силуэтам|абрисам|профилям
контурами|силуэтами|абрисами|профилями
контурах|силуэтах|абрисах|профилях
контуре|силуэте|абрисе|профиле
a|b|c|d|e|f|g|h`;
const subst = `$1,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);