$re = '/((^[^|\n]+\||\G)[^|\n]+)\|/m';
$str = 'контура|силуэта|абриса|профиля
контурам|силуэтам|абрисам|профилям
контурами|силуэтами|абрисами|профилями
контурах|силуэтах|абрисах|профилях
контуре|силуэте|абрисе|профиле
a|b|c|d|e|f|g|h';
$subst = "$1,";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;