import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?<!\\.\\s+)((?:\\p{Lu}[\\p{L}0-9_-]+)(?:\\s+\\p{Lu}[\\p{L}0-9_-]+)*)\\b";
final String string = "Separated-word-by-hyphen great this part is working\n"
+ "I love Basketball. NBA mean: TheNational Basketball Association \n"
+ "the word. NBA here sould be excluded because there's a dot followed by a space and a word who begin by a capital letters\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}