const regex = /\b(?<!\.\s+)((?:\p{Lu}[\p{L}0-9_-]+)(?:\s+\p{Lu}[\p{L}0-9_-]+)*)\b/ug;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?<!\\.\\s+)((?:\\p{Lu}[\\p{L}0-9_-]+)(?:\\s+\\p{Lu}[\\p{L}0-9_-]+)*)\\b', 'ug')
const str = `Separated-word-by-hyphen great this part is working
I love Basketball. NBA mean: TheNational Basketball Association
the word. NBA here sould be excluded because there's a dot followed by a space and a word who begin by a capital letters
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}