package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*<asi-page value="(\d+)" \/>`)
var str = `<asi-page value="34" />`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}