re = /^\s*<asi-page value="(\d+)" \/>/m
str = '<asi-page value="34" />'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result