import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\{(?:(?!\\{\\{|\\}\\}).)*\\}\\}";
final String string = "{{number}}-{{$index}}\n"
+ "{{number}} all kinds of things are here 190378ckkvmnlfadg@#$@#$@#!%$@$%!~W { §É4ΦX2░☻â&4♫♫Y╧╬ including another {{! {{$index}}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}