const regex = /{{(?:(?!{{|}}).)*}}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{{(?:(?!{{|}}).)*}}', 'g')
const str = `{{number}}-{{\$index}}
{{number}} all kinds of things are here 190378ckkvmnlfadg@#\$@#\$@#!%\$@\$%!~W { §É4ΦX2░☻â&4♫♫Y╧╬ including another {{! {{\$index}}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}