import re
regex = re.compile(r"(([^,]*,){2})", flags=re.MULTILINE)
test_str = ("nsi_file_status,host=pi-test.rusklimat.ru Message_000_113_CountRecord=5,endTime=1695132572,iterator=1,longtime=30,processFail=0,processFailDomainException=0,processFailException=0,processFailInvalidArgumentException=0,processSuccess=5,processTotal=5,startTime=1695132542,timeStamp=1695132542 1695132700000000000\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")