using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+(?=[^/]*/$)";
string input = @"https://example.com/notwantedstring/anotherunwantedstring/i-want-this-string/
https://www.example.com/abdfsg63/sfdgfv/dfgffk/sf-adfgdg-fgfg-1/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}