$re = '~\w+(?=[^/]*/$)~m';
$str = 'https://example.com/notwantedstring/anotherunwantedstring/i-want-this-string/
https://www.example.com/abdfsg63/sfdgfv/dfgffk/sf-adfgdg-fgfg-1/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);