#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*\/shell\/.*$"
Local $sString = "." & @CRLF & _
"./svg" & @CRLF & _
"./svg/safari-pinned-tab.svg" & @CRLF & _
"./svg/safari-pinned-tab-2.svg" & @CRLF & _
"./svg/safari-pinned-tab-1.svg" & @CRLF & _
"./favicon.ico" & @CRLF & _
"./index.html" & @CRLF & _
"./shell" & @CRLF & _
"./shell/android-chrome-192x192.png" & @CRLF & _
"./shell/android-chrome-512x512.png" & @CRLF & _
"./img" & @CRLF & _
"./img/icons" & @CRLF & _
"./img/icons/favicon-16x16.png" & @CRLF & _
"./img/icons/safari-pinned-tab.svg" & @CRLF & _
"./img/icons/apple-touch-icon-120x120.png" & @CRLF & _
"./img/icons/android-chrome-192x192.png" & @CRLF & _
"./img/icons/apple-touch-icon.png" & @CRLF & _
"./img/icons/apple-touch-icon-152x152.png" & @CRLF & _
"./img/icons/apple-touch-icon-180x180.png" & @CRLF & _
"./img/icons/apple-touch-icon-76x76.png" & @CRLF & _
"./img/icons/android-chrome-512x512.png" & @CRLF & _
"./img/icons/msapplication-icon-144x144.png" & @CRLF & _
"./img/icons/mstile-150x150.png" & @CRLF & _
"./img/icons/apple-touch-icon-60x60.png" & @CRLF & _
"./img/icons/favicon-32x32.png" & @CRLF & _
"./robots.txt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")