# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.*\/shell\/.*$"
test_str = (".\n"
"./svg\n"
"./svg/safari-pinned-tab.svg\n"
"./svg/safari-pinned-tab-2.svg\n"
"./svg/safari-pinned-tab-1.svg\n"
"./favicon.ico\n"
"./index.html\n"
"./shell\n"
"./shell/android-chrome-192x192.png\n"
"./shell/android-chrome-512x512.png\n"
"./img\n"
"./img/icons\n"
"./img/icons/favicon-16x16.png\n"
"./img/icons/safari-pinned-tab.svg\n"
"./img/icons/apple-touch-icon-120x120.png\n"
"./img/icons/android-chrome-192x192.png\n"
"./img/icons/apple-touch-icon.png\n"
"./img/icons/apple-touch-icon-152x152.png\n"
"./img/icons/apple-touch-icon-180x180.png\n"
"./img/icons/apple-touch-icon-76x76.png\n"
"./img/icons/android-chrome-512x512.png\n"
"./img/icons/msapplication-icon-144x144.png\n"
"./img/icons/mstile-150x150.png\n"
"./img/icons/apple-touch-icon-60x60.png\n"
"./img/icons/favicon-32x32.png\n"
"./robots.txt")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.