using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s(?=[\s"":{}])";
string substitution = @"";
string input = @"{
""failure"": {
""type"": ""Blah"",
""message"": ""Unrecognised Message: \""Good job!\"" Sir""
}
}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}