import Foundation
let pattern = #"\s(?=[\s":{}])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{
"failure": {
"type": "Blah",
"message": "Unrecognised Message: \"Good job!\" Sir"
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)