const regex = /^(.*.+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*.+)$', 'gm')
const str = `// Resources for SEEN0001.TXT
#character '美佐枝'
#character '春原'
#character 'ボタン'
<0000> \\{美佐枝}You little goblin...
<0001> Unable to contain her fury, Misae grabs both of Sunohara's legs...
<0002> \\{春原}Heh?
<0003> ...and proceeds to use her killing move, The Giant Swing.
<0004> \\{美佐枝}Uryaaaaaaaaaaaaaaaaaaa!
<0005> \\{春原}Uwaaaaaaaaaaaaaah!
<0006> \\{ボタン}Puhiiii.
<0007> \\{春原}Uwaaaaaaaaaaah!
<0008> \\{春原}Uwaaaaaaaaaaah!
<0009> \\{春原}Uwaaaaaaaaaaah!
<0010> \\{春原}Geeh!
<0171> \\size{intA[1001]}*BOOM*\\size{}\\shake{4}
<0145> \\size{intA[1001]}Dammit! Stupid rugby players!!\\size{}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}