import re
regex = re.compile(r"^(.*.+)$", flags=re.MULTILINE)
test_str = ("// Resources for SEEN0001.TXT\n\n"
"#character '美佐枝'\n"
"#character '春原'\n"
"#character 'ボタン'\n\n"
"<0000> \\{美佐枝}You little goblin...\n"
"<0001> Unable to contain her fury, Misae grabs both of Sunohara's legs...\n"
"<0002> \\{春原}Heh?\n"
"<0003> ...and proceeds to use her killing move, The Giant Swing.\n"
"<0004> \\{美佐枝}Uryaaaaaaaaaaaaaaaaaaa!\n"
"<0005> \\{春原}Uwaaaaaaaaaaaaaah!\n"
"<0006> \\{ボタン}Puhiiii.\n"
"<0007> \\{春原}Uwaaaaaaaaaaah!\n"
"<0008> \\{春原}Uwaaaaaaaaaaah!\n"
"<0009> \\{春原}Uwaaaaaaaaaaah!\n"
"<0010> \\{春原}Geeh!\n"
"<0171> \\size{intA[1001]}*BOOM*\\size{}\\shake{4}\n"
"<0145> \\size{intA[1001]}Dammit! Stupid rugby players!!\\size{}\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")