$re = '/(?:^|\|)(r)(?:\||$)/m';
$str = 'r
sql|r|python
c
vba|r
r|java';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);