using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<.*?>|&\w++;)(*SKIP)(*F)|micro";
string substitution = @"µ";
string input = @"micro";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}