use strict;
my $str = 'micro';
my $regex = qr/(?:<.*?>|&\w++;)(*SKIP)(*F)|micro/p;
my $subst = 'µ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";