package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.{8,}$`)
var str = `123
abcd
12345678
z tr
*7fjkfd
jfdk984dkgjkdf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}