$re = '/^.{8,}$/m';
$str = '123
abcd
12345678
z tr
*7fjkfd
jfdk984dkgjkdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);