#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\d)_(?=\d+-)"
Local $sString = "scaffold_97606_2-BACs_-__SP1_1" & @CRLF & _
"UELV01165908.1_2-BACs_+__SP2_2" & @CRLF & _
"UXGC01046554.1_9-702_+__SP3_3" & @CRLF & _
"scaffold_12002_1087-1579_-__SP4_4" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")